Results 1 to 6 of 6
  1. #1
    RC Competitor
    Join Date
    Aug 2008
    Posts
    76

    ESC MMMv2 Issue ?

    Having i problem with the forward throttle. As soon as i push the throttle (1%) my Neu motor goes like say as it would do on 20% throttle. ON reverse i can nicely start with 1% it will go 1% speed but not on forward. Any ideas ?
    what am i doing wrong. Tryied all setting on the ESC but no changes.
    using 2.4Ghz 3Pm Spectrum. did calibrate. Still no luck...

  2. #2
    RC Turnbuckle Jr.
    Join Date
    May 2007
    Location
    Kerrville Tx
    Posts
    4,997
    send it to castle! and get the v3

  3. #3
    RC Competitor
    Join Date
    Aug 2008
    Posts
    76
    thats whats wrong with it ? hmm i just bought the ESC 3 weeks ago. I guess i got the last V2 how can you tell they have V3 out. IF its a problem they better have it under warranty and replace it for me for Free i hope

  4. #4
    RC Champion
    Join Date
    Jan 2007
    Location
    Hollywierd, FL
    Posts
    2,779
    Try swapping any 2 wires going to the motor. Sending it in for a v3 is an option, but you have a 1 year warranty on it and can do that anytime in that year.
    Run it, break it, fix it, love it :]=~

  5. #5
    RC Competitor
    Join Date
    Sep 2008
    Posts
    91
    im not sure if this will solve your problems however, if you want to wait a few more days castle stated they would be releasing a new software update for MMM on there website under the download section (something after ver 3.11)... hope it works for you when they release it.

  6. #6
    RC Qualifier
    Join Date
    Sep 2008
    Posts
    606
    Sounds like you have it calibrated or programmed wrong- start from scratch ensuring you have everything set correctly on the radio (nothing reversed on the throttle channel).

    Set the esc via castle link to:

    70% punch control
    30-40& reverse
    forwards-brake with reverse lockout
    timing to lowest or low
    drag the throttle curve down a little bit near the start- that will add a bit of exponential and improve the low speed controllability.
    look at the dead band setting and perhaps decrease it (or increase it).

    Read the manual carefully- lots of info to be gleaned.
    Dont consult me, just read the FAQ.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •