Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    May 2008
    Location
    NYC!
    Posts
    16

    slash with 5700 mamba sidwinder glitches??????

    hey got my first brushless system but having some problems...

    first off i have the stock slash with mamba 5700 sidewinder and spektrum dx2..

    i installed my 5700 sidwinder system but when i go to run the slash it jerks for a little and the steering stops working?

    then it would stop..car would run for 2 mins and same thing happens..

    my buddy told me it could be the digital servo so i changed it out and put in a spektrum servo that i have in my drift car and that solved the problem ( i thought) the car started to run no problem but it started up again and when i get half way down the block it losses control..no steering etc..

    now the same thing happens..not as much but but what could it be?..could the sidwinder be damaged or i recived a DOA..its new i got it 3 days ago and i also put deans on it..
    Everything Last edited by Misbehavin

  2. #2
    RC Champion
    Join Date
    Jun 2008
    Posts
    1,164
    Totally sure about connections? They're secure? In the right receiver slot?
    English. It's your language. Learn to type it.

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Mar 2006
    Location
    MI
    Posts
    4,478
    Do you have the rx antenna ran outside of the reciever box?
    I tried being reasonable, I didn't like it.

  4. #4
    RC Qualifier
    Join Date
    Jan 2006
    Posts
    549
    I had a very similar problem. Turned out that the little green light was going off on the spektrum reciever whenever this would happen. For some reason the reciever was shutting down on me. I sent in the reciever and the one I got back was perfect. Watch that green light. If it blinks or goes out its probablly a bad one
    Brushless makes everything taste better

  5. #5
    RC poster
    Join Date
    Nov 2004
    Location
    Toronto, Ontario, Canada
    Posts
    14
    It could also be interference from the motor and esc wiring. When you are running a brushless system it draws a greater current, the higher current can cause the dx2 to glitch a bit. try moving your wires if you can, or wrapping them in a layer or two of electrical tape.

  6. #6
    RC poster
    Join Date
    May 2008
    Location
    NYC!
    Posts
    16
    Quote Originally Posted by Dragonfueled
    I had a very similar problem. Turned out that the little green light was going off on the spektrum reciever whenever this would happen. For some reason the reciever was shutting down on me. I sent in the reciever and the one I got back was perfect. Watch that green light. If it blinks or goes out its probablly a bad one

    this was happening also to me but when my buddy re-set the esc and the receiver and controler for me it stoped but starts to stall out...
    Everything Last edited by Misbehavin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •