Results 1 to 7 of 7

Hybrid View

  1. #1
    RC Racer
    Join Date
    Jun 2005
    Posts
    204

    Calibrate Your Esc!!!!!!!!!!!

    Ok, i thought it was just the initial batch of Slashes that came out.... but 5 out of 5 slashes that we checked at my LHS were not setup appropriately........ check yours.... lift the tires off the ground, hit full throttle.... if the light on your ESC doesnt turn green....... YOURE NOT GETTING FULL THROTTLE!!!!!!! This has been on all the slashes i have looked at... 5 total.... im the only one with an aftermarket radio in it..... just bringing it to people attention!!!!

    MUD

  2. #2
    RC Racer
    Join Date
    Jun 2008
    Posts
    117
    ...good find! Im sure everyone will be making sure

  3. #3
    RC Racer
    Join Date
    Jun 2008
    Posts
    117
    Also, after adjusting the esc, and getting the "green" light, was there a noticable gain in speed??

  4. #4
    RC Racer
    Join Date
    Jun 2005
    Posts
    204
    a lil yes like it kicks in gear

  5. #5
    RC Champion
    Join Date
    Feb 2003
    Posts
    2,620
    Quote Originally Posted by redmann11
    Also, after adjusting the esc, and getting the "green" light, was there a noticable gain in speed??
    No, its still slow as can be.

  6. #6
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,650
    this might be happening to more than just the slash....both of my new vxl escs weren't programmed properly when i got them.
    Associated rc8TE, rc8.2E, B4.2, Ofna LX2E, Slash

  7. #7
    RC Qualifier
    Join Date
    Jun 2008
    Posts
    397
    I had 2 program mine also,but only cause I put in my after market radio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •