Search:

Type: Posts; User: sxipro02

Page 1 of 2 1 2

Search: Search took 0.25 seconds.

  1. Replies
    15
    Views
    1,410

    I would love to see some pics of your setup. Are...

    I would love to see some pics of your setup. Are you using the stock outdrives with one motor?
  2. Replies
    5
    Views
    434

    I had some issues with my new evx-2 also when I...

    I had some issues with my new evx-2 also when I first bought it, I called traxxas about voiding the warranty and said they would NOT void it if it was done correctly and not causing the problem....
  3. Replies
    15
    Views
    1,410

    the 12t's made my batterys over heat, I'm...

    the 12t's made my batterys over heat, I'm guessing because they couldnt get the current they needed, I think the lipos might be able to push them better. Im going to gear up first and see what...
  4. Replies
    56
    Views
    48,395

    Sticky: Here is some pics of mine after I got it...

    Here is some pics of mine after I got it finished. I added a lipo smart stop since then but thats aboout it.

    http://www.youtube.com/watch?v=Tvini3UPUnc

    Dont mind the kids and the stuff in the...
  5. Replies
    15
    Views
    1,410

    Wouldnt that be a little pricey lol. I just...

    Wouldnt that be a little pricey lol. I just rebuilt my Villain iv a few months ago, I used a evx-2, titan 550's, run 4s lipo with a smart stop, EX props and water cooled everything. Runs pretty...
  6. Replies
    1
    Views
    212

    U-joints failing...

    I've ony had my boat out a few times since I finished it, its running great on 4s lipo and the evx2. Im happy with the speed and runtime but I have to keep it trimmed way down so I dont pop the...
  7. Replies
    4
    Views
    213

    Also I have found it very helpfull to slide the...

    Also I have found it very helpfull to slide the main shaft toward the rear of the boat to allow the spur to have more room to slide out, last time I replaced mine I also removed one side of the...
  8. Replies
    5
    Views
    434

    My mini e revo bl did that all the time when it...

    My mini e revo bl did that all the time when it got wet even though it was waterproof. Traxxas said it was a defective esc. I never fixed it, just upgraded to a castle lol. Only thing I could suggest...
  9. Replies
    5
    Views
    717

    What run time did you get on the nihm packs? I...

    What run time did you get on the nihm packs? I got around 8-10 on two 3000mah packs in series. I guess Im wasting a lot of power with heat lol.
    Lipo is the way to go for sure, my mini e-revo and...
  10. Replies
    5
    Views
    717

    30 minute runtime???? That's awesome!!! Looks...

    30 minute runtime???? That's awesome!!! Looks great
  11. Thread: Success!!!!!!

    by sxipro02
    Replies
    4
    Views
    212

    Thanks I'll trim it down some. I was trying to...

    Thanks I'll trim it down some. I was trying to avoid sharp turns in the routing. It flows pretty good now, sprays out about 3-4 inches from the side. I'm gonna order some more lipos tonight. I'm...
  12. Thread: Success!!!!!!

    by sxipro02
    Replies
    4
    Views
    212

    Success!!!!!!

    finnally got the old Villain running! I think my esc issue was caused by a faulty crystal in the reciever, all is good now. Runtime was around 8-10 minutes. Temps were as follows esc-110f ...
  13. Replies
    0
    Views
    179

    EVX-2 dead again.

    Put a set of Titan 550's in the villain Friday and tested it out on the bench just to make sure everything was good to go and it was fine. Took it out to the lake Saturday and it won't turn on, green...
  14. Replies
    4
    Views
    193

    Thanks man. That's some good info, I'll check...

    Thanks man. That's some good info, I'll check that out after I install my 21t 550's after work today. The 12t's are a lost cause, I should have read a bit more about them before I bought em.
  15. Replies
    4
    Views
    193

    traxxas help line veified the voltage for the 12t...

    traxxas help line veified the voltage for the 12t is 8.4 max and not for use in villain/villain ex/e-maxx ect. prob just throw in the stock motors and by a set of 550 19t titans unless theres a...
  16. Replies
    4
    Views
    193

    best suggestion for lowering temps...

    Im using this setup now

    EVX-2 water cooled
    dual titan 12t water cooled
    ex props
    two 3000mah 8.4V
    stock 14t gears

    motors and esc run cool but batteries got stupid hot, should I just ditch...
  17. Replies
    14
    Views
    826

    Yep. Thats the number on the servo. Worked great,...

    Yep. Thats the number on the servo. Worked great, got about a 3 minute run in before the batteries were dead.
    Only problem I have now is that the batteries got so hot one actually melted the heat...
  18. Replies
    14
    Views
    826

    went to my lhs and picked up a waterproof servo,...

    went to my lhs and picked up a waterproof servo, forgot the number but it was only 5 bucks more. Should be up and running again tonight.
  19. Replies
    14
    Views
    826

    Ok so tonight I put in the TQ reciever and...

    Ok so tonight I put in the TQ reciever and reprogramed the esc, it is now turning on most of the time but sometimes the light flickers and the steering dosent work at all. Guess the new Traxxas servo...
  20. Replies
    14
    Views
    826

    still using the stocker, I put in a crystal out...

    still using the stocker, I put in a crystal out of a old losi controller I had just for a test run. I plan on putting in a traxxas TQ am reciever and transmitter I have left over from a mini e-revo...
  21. Replies
    14
    Views
    826

    I figured, seems like esc or reciever. I'll look...

    I figured, seems like esc or reciever. I'll look into it more tonight.
  22. Replies
    14
    Views
    826

    really? I thought I remembred reading it was good...

    really? I thought I remembred reading it was good for 16.8 somewhere. Oh well, guess I'll try unplugging them and see if it will turn on then.
  23. Replies
    14
    Views
    826

    EVX-2 wont turn on???

    I just got my villain IV put back together after a fresh build and new paint, everything was working fine for about one minute untill I brought it in for a quick look. When I put it back into the...
  24. Replies
    8
    Views
    385

    wow, that looks pretty quick man!!!

    wow, that looks pretty quick man!!!
  25. Replies
    7
    Views
    334

    I wasnt thinking it would work lol, I think its a...

    I wasnt thinking it would work lol, I think its a traxxas cooler, I know the motor coolers were from traxxas but cant rember the brand on the other one and it hasnt shown up yet. Im also still...
Results 1 to 25 of 28
Page 1 of 2 1 2