Search:

Type: Posts; User: whowerton

Search: Search took 0.23 seconds.

  1. Replies
    14
    Views
    975

    Did you change up the oils in your front and rear...

    Did you change up the oils in your front and rear diffs? Just curious if you did, what you were using.
  2. Replies
    8
    Views
    578

    I'll try that when I get home. Thanks Ducati777....

    I'll try that when I get home. Thanks Ducati777. Was trying to think of a good way to test for binding.

    Sent from my Motorola Electrify using Tapatalk
  3. Replies
    8
    Views
    578

    Well i did some digging and one of the bearings...

    Well i did some digging and one of the bearings in the rear left axle carrier doesn't spin very well. Not sure if its my issue but might help. Thx for the help guys

    Sent from my Motorola Electrify...
  4. Replies
    8
    Views
    578

    Didn't think to look there. Thanks, hopefully...

    Didn't think to look there. Thanks, hopefully thats the culprit.

    Sent from my Motorola Electrify using Tapatalk
  5. Replies
    8
    Views
    578

    Some heating issues

    Looking for some guidance from the pro's. My Revo is 3 months old has been ran around 15 times. Recently I've been experiencing some heating issues with the motor and ESC. I am running the 18/54...
  6. Replies
    5
    Views
    792

    The receiver is a 2.4 and I've had it for around...

    The receiver is a 2.4 and I've had it for around a year and never had any problems with interference. I will try to re-link and try switching the servo's and see what happens. Thanks for the help! ...
  7. Replies
    5
    Views
    792

    Servo went nuts!

    Hello everyone. I was looking for some guidance regarding my throttle/brake servo. I have a 3.3, 2.4 link Jato and was driving it the other day and noticed the servo was moving without me touching...
Results 1 to 7 of 7