Search:

Type: Posts; User: llinneman

Search: Search took 0.03 seconds.

  1. Replies
    4
    Views
    783

    PROBLEM FIXED: Battery Draining issue fixed, Inner Side Plates NEEDS to be re-worked

    PROBLEM FIXED DR-1 : Part 6333, Inner Side Plates crack after hard tail landing. I figured out the problem with the battery draining so quick. I took it apart and found that both inner main frame...
  2. Replies
    4
    Views
    783

    HELP Same issue you had

    Hey there TQi! I am having the same issue you had. Did you ever find a cure for the battery LVD problem? I would love to know. I am in desperate need of help.

    I too am having issues with the...
  3. Replies
    34
    Views
    611

    Cool. Gonna make the switch to lipos. Thanks for...

    Cool. Gonna make the switch to lipos. Thanks for all your info!
  4. Replies
    34
    Views
    611

    Cool, thanks again for the info. I will for sure...

    Cool, thanks again for the info. I will for sure get a lipo and not use these crappy NiMH batteries anymore. I really appreciate your help! Take care!
  5. Replies
    34
    Views
    611

    50togo, do you/can you use 2 lipos with a series...

    50togo, do you/can you use 2 lipos with a series connector like you can with the series 1 batteries? Also, If you are using 1 lipo, do you need to add weight to the other side where the other...
  6. Replies
    34
    Views
    611

    Right on, thanks for the lipo info. Also, I just...

    Right on, thanks for the lipo info. Also, I just tested with a normal size 6-cell 3200 mAh NiMH that I taped onto the top of the truck and it worked fine, so the problem must be with the crappy...
  7. Replies
    34
    Views
    611

    Yeah the motor and ESC get very hot very quick. ...

    Yeah the motor and ESC get very hot very quick. I would love to get lipos for it, but I want to make sure that the problem is in fact the batteries and not the ESC. Do the symtoms sound like it is...
  8. Replies
    34
    Views
    611

    The LED is a constant red. I have also made sure...

    The LED is a constant red. I have also made sure that I am in profile 1.
  9. Replies
    34
    Views
    611

    I discharged/charged the batteries again. ...

    I discharged/charged the batteries again. But,here is the problem I am still having. It ran really fast (like it used to) for about 30 seconds and then, all of a sudden it was at a crawl. I...
  10. Replies
    34
    Views
    611

    Battery Problem! Please help!

    I have a 1/16 Slash and I am using 2 Traxxas Series 1 batteries with a serial connector. One of the batteries is brand new. I charged both batteries to 8.4v on a peak charger and put them in the...
  11. Replies
    10
    Views
    595

    Thanks for the help. I'll try a low voltage alarm.

    Thanks for the help. I'll try a low voltage alarm.
  12. Replies
    10
    Views
    595

    Stock Slash XL-5 ESC Question

    Will the stock blue XL-5 esc work with a Lipo battery?
Results 1 to 12 of 12